문제
N×N 게임판에 수가 적혀져 있다. 이 게임의 목표는 가장 왼쪽 위 칸에서 가장 오른쪽 아래 칸으로 규칙에 맞게 점프를 해서 가는 것이다.
각 칸에 적혀있는 수는 현재 칸에서 갈 수 있는 거리를 의미한다. 반드시 오른쪽이나 아래쪽으로만 이동해야 한다. 0은 더 이상 진행을 막는 종착점이며, 항상 현재 칸에 적혀있는 수만큼 오른쪽이나 아래로 가야 한다. 한 번 점프를 할 때, 방향을 바꾸면 안 된다. 즉, 한 칸에서 오른쪽으로 점프를 하거나, 아래로 점프를 하는 두 경우만 존재한다.
가장 왼쪽 위 칸에서 가장 오른쪽 아래 칸으로 규칙에 맞게 이동할 수 있는 경로의 개수를 구하는 프로그램을 작성하시오.
입력
첫째 줄에 게임 판의 크기 N (4 ≤ N ≤ 100)이 주어진다. 그 다음 N개 줄에는 각 칸에 적혀져 있는 수가 N개씩 주어진다. 칸에 적혀있는 수는 0보다 크거나 같고, 9보다 작거나 같은 정수이며, 가장 오른쪽 아래 칸에는 항상 0이 주어진다.
출력
가장 왼쪽 위 칸에서 가장 오른쪽 아래 칸으로 문제의 규칙에 맞게 갈 수 있는 경로의 개수를 출력한다. 경로의 개수는 2^63-1보다 작거나 같다.
예제 입력 1
4
2 3 3 1
1 2 1 3
1 2 3 1
3 1 1 0
예제 출력 1
3
풀이
처음에는 조건을 안 보고 냅다 DFS로 풀어보았다. 당연히 시간초과!
DP로 풀 때는 약간의 지피티 도움을 받았다. 거의 다 생각했는데 아쉽다..
틀린 코드
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.StringTokenizer;
public class Main {
static int n;
static long cnt;
static int[][] arr, dp;
public static void main(String[] args) throws IOException {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
StringTokenizer st;
n = Integer.parseInt(br.readLine());
arr = new int[n][n];
for (int i = 0; i < n; i++) {
st = new StringTokenizer(br.readLine());
for (int j = 0; j < n; j++) {
arr[i][j] = Integer.parseInt(st.nextToken());
}
}
dp = new int[n][n];
dp[0][0] = 1;
DFS(0, 0);
System.out.println(cnt);
}
static void DFS(int x, int y) {
if (x == n - 1 && y == n - 1) {
cnt++;
return;
}
int jump = arr[x][y];
if (x + jump <= n - 1) {
dp[x + jump][y]++;
DFS(x + jump, y);
}
if (y + jump <= n - 1) {
dp[x][y + jump]++;
DFS(x, y + jump);
}
}
}
정답 코드
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.StringTokenizer;
public class Main {
public static void main(String[] args) throws IOException {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
StringTokenizer st;
int n = Integer.parseInt(br.readLine());
long[][] arr = new long[n][n];
for (int i = 0; i < n; i++) {
st = new StringTokenizer(br.readLine());
for (int j = 0; j < n; j++) {
arr[i][j] = Integer.parseInt(st.nextToken());
}
}
long[][] dp = new long[n][n];
dp[0][0] = 1;
for (int i = 0; i < n; i++) {
for (int j = 0; j < n; j++) {
if (i == n-1 && j == n-1) break; // 타겟 지점
int jump = (int) arr[i][j];
if (i + jump <= n - 1) dp[i+jump][j] += dp[i][j];
if (j + jump <= n - 1) dp[i][j+jump] += dp[i][j];
}
}
System.out.println(dp[n-1][n-1]);
}
}
'알고리즘 > 백준' 카테고리의 다른 글
[백준] 21921: 블로그 (JAVA) (1) | 2024.09.28 |
---|---|
[백준] 1238: 파티 (JAVA) (1) | 2024.09.25 |
[백준] 15903: 카드 합체 놀이 (JAVA) (0) | 2024.09.23 |
[백준] 11659: 구간 합 구하기 4 (JAVA) (0) | 2024.09.01 |
[백준] 1759: 암호 만들기 (JAVA) (0) | 2024.07.16 |